Details

    • Type: Task
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.5
    • Component/s: None
    • Labels:
      None

      Description

      If we are to integrate with allen-SDK, we should have matplotlib > 1.5.0
      The current Matplotlib HTML5 backend that we are maintaining is not compatible with the newest matplotlib API.

      • _png.write_png change signature
      • Image.flipud_out has been removed and we need to do it in a numpy representation

      Attached we have the required fixes for TVB to work with Matplotlib 1.5.
      As we do to maintain an if in the code with different calls based on matlab version, we should update the matplotlib installations on the build machines before committing this.

        Attachments

          Expenses

            Activity

              People

              • Assignee:
                lia.domide Lia Domide
                Reporter:
                lia.domide Lia Domide
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Time Tracking

                  Estimated:
                  Original Estimate - 2 days Original Estimate - 2 days
                  2d
                  Remaining:
                  Remaining Estimate - 0 minutes
                  0m
                  Logged:
                  Time Spent - 2 days, 1 hour
                  2d 1h