It's minor but the name of the signal selector in the Animated time-series sounds a bit odd.
'signal 1 components'.
I'd name it something like "Input data 1: signals"; "Select signals from Input Data 1"; "Select time-series from Input Data 1" ...
The same applies for the svg time-series visualizer.
Instead of "Select signal components", it'd be better "Select Input Signals" or "Select time-series from Input Data".
Because these visualizers are not generic line plot visualizers (yet), we can use the word 'time-series', instead of signal; it won't be referring to the datatypes but to the individual traces.
My problem with signal components is that in engineering (and signal processing) the components of a signal are referring to a set of simpler functions into which a signal can be broken down. When we combine this 'components' we get the original signal. This terminology is used in analysis such as PCA and ICA.
Also, as long as we have more than one visualizers, then the naming should be consistent across them.